Seit einiger Zeit ist ein Fehler im Zusammenspiel mit Atlassian Confluence und Google Chrome ab v50.x bekannt, wegen dem der Editor nur sehr schmal angezeigt wird.

EditInChrome

» Siehe auch: https://jira.atlassian.com/browse/CONF-41035

Das Problem soll mit Confluence ab v5.9.7 gelöst sein.

Allerdings scheint das Problem mit Chrome v50.0.2661.87 m egal ob unter Linux oder Windows ebenfalls gelöst zu sein.
Wer also kurzfristig kein Confluence-Update durchführen kann, sollte seinen Browser zügig updaten.